Buy all your VW California Accessories at the Club Shop Visit Shop

Water pump not working



The tap has stopped working in my van, I've checked the fuse which is ok, I then measured the voltage supplied to the pump at the back of the van and this is 12v. The tap changes the voltage from 0 to 12 so am very puzzled why my pump down work. I even bought a new pump and again this doesn't work when I connect to the 12v supply cable which feeds into the water tank?
I'd be grateful of any ideas....
Many thanks
Does the tap click when you lift the lever :?:
Yes you can hear a click. I suspect this is the relay switching on the 12 supply to the pump?
Its does sound strange if you are getting 12v at the pump when the tap is open
Apart from the new pump being faulty as well I could think what else it could be.
Our water pump stopped working on the first day of our recent trip to France. Not fun having 20 litres of water you can't get access too. Anyway, long story short. Once home as part of the cleaning out process I decided to investigate. I checked to see that the pump was getting power when I opened the tap - this appeared to be fine. The tap made a click on operating it. Good. So I removed the pump and connected it directly to a battery. It worked perfectly. Grrr.

Now it may be slightly different in the T5 California, but on looking at some pictures they appear to be fitted with the same unit I have in my 2001 'Generation'. There is no relay to the best of my knowledge but the micro switch in the tap gets carbon on the contacts which restrict the flow of power to the pump. The tap can be removed and dismantled (its all push fit) to reveal the offending item. I cleaned the contacts by rubbing them with some very fine sandpaper, reassembled, tested and reinstalled. We now have pumped water again!
Thought I'd add my experience here, might help someone.

There we are down at the beach, wanted to clean the dishes and no pump :-( Switch was clicking but no water. Checked fuse (nice and accessible aren't they) but that was OK so had to admit defeat with Mrs. B upset that the best feature of the van didn't work.

Got home, did diagnostics, switch was closing circuit (can be disconnected under counter) quite happily. Into the wardrobe, lift flap, disconnect pump and reading 12.5 volts when switch closed - still no pump action.

Open up the water tank and fish out the pump - fully sealed unit not comfortable about buying and fitting a new one. Looked at the bottom of the pump and you can see the impeller and a couple of prongs sticking out that could be twisted with pliers. Seemed a bit stiff, so twisted more and it gradually loosened off and started to spin freely - so maybe just stuck from winter?

Tried the tap again and now we have water :) well happy.

Moral of story, use it or lose it? At least need to check before next major trip.

Happy camping.
I have a similar problem with my water tap. Can you help.
The pump and fuse are fine, I tested them and it all works. But the pump does not come on every time. Sometimes it works and most times it does not.
I believe I have a micro switch issue.
How do I access the switch to give it a good clean? Is the switch actually in the tap or somewhere else in the wiring system?
I have loosened the tap and had a little look but am afraid of damaging something if I actually remove it completely.
You seem to have achieved this. Can you advise how you manged and how fragile the tap actually is?
Many thanks
debarros said:
I have a similar problem with my water tap. Can you help.
The pump and fuse are fine, I tested them and it all works. But the pump does not come on every time. Sometimes it works and most times it does not.
I believe I have a micro switch issue.

Hi Jose,
I'll do my best to help. Firstly what kind of tap do you have? The earlier Westfalia's had a tap on a hose that could be used outside the window as a cold shower. The later ones, as I have, are fixed to the sink. I don't have any experience of the earlier style of tap although it works on a similar principal of having a micro switch to activate the pump when the demand is there.

Anyway. The later style tap is fairly simple to remove, if a little fiddly to get to because it's behind the sink. There's a water pipe attached using a jubilee clip - removed using a short flat blade screwdriver. There's an electric supply - the circuit is broken/completed by the micro switch. This is disconnected at a plastic block connector between the tap and the electrical harness which should pull apart. You can check the circuit to the pump at this point before you remove the tap - just in case it's not the tap. To finally remove the tap there is a large plastic nut that clamps the tap in place. You don't really need to use a spanner on this as it can be released by gripping the nut with your fingers then rotating the tap by the base, on the top side of the kitchen in an anticlockwise direction. Once it's loose the nut should spin off easily enough allowing you to remove the tap completely.

What I did next is a bit more tricksy. I used no tools other than brute force and a bit of good luck. My thinking was if I break the tap I need to replace it anyway, if I dismantle it without a breakage then I'm onto a winner. So I gripped opposite sides of the tap - the bit you use to switch it on and the bit the water flows from then with a bit of a twist and pull the two bits will separate. They are basically clipped together. Once these parts are separated you'll be able to get to the micro switch and clean it with some fine sandpaper. Be very careful to examine how the switch is assembled as it's got a tiny plate spring on that can easily be lost, but cause the switch to not work correctly if it's incorrectly reassembled - I learnt that the hard way. Also when you reassemble the tap take care to line everything back up carefully. If you don't it won't locate correctly and doesn't fully click back together. I reckon if you get this far you will probably be able to fix your tap and reassemble it successfully.

Good luck and let us know how you go.
Hi Phil, stayed away from the forum for most of last year so missed your very welcomed reply. In the end bought a new tap from vw in France and all was ok. Problem was with the micro switch . It was easy to fix but very fiddly.... Thanks again best wishes for 2016
Really helpful thank you - checked the electrical connections that were tucked away behind the sink. Shorting across the connections confirmed the pump was working.
Used a plastic spudger to lever off the arm that operates the tap. It came off with a bit of force. Pinged the microswitch with my finger and it worked!!
Pushed the arm back on and it seemed to work but I hadn't lined it up correctly because it only turned the tap on when I pushed it the wrong way. Reconnected the arm having turned it 45 degrees and it worked properly.
I guess the microswitch had just got stuck apart.
Thanks again for starting the thread and giving me the confidence to be a little more forceful in investigation.
I've had 3 different issues already with the water system in the California. I've learned a few things as I fixed all of them, including replacing the water pump myself, so I decided to document it all in case it helps others. Here's a first guide on how to identify which problem you are actually experiencing:

I hope it helps! I'll update this thread as I complete the detailed step-by-step guides (feel free to drop by that article and give me some claps and comments for motivation!)

Similar threads